I got an old phone from my daughter so I could use the Google Mini. Google Mini requires Android 5 or above. The phone I was given has Android 4.8 (max update) so it wouldn't work. To my point, make sure phone or tablet has the correct app (or at least is updatable) to be compatible. I think unlocked...