Announcement

Collapse
No announcement yet.

Windows 10/Microsoft Edge Update

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Windows 10/Microsoft Edge Update

    Anyone notice how slow and staggery Microsoft Edge is after the most recent Windows 10 Update. It was already slower than Chrome before, but now is nearly unusable. My mouse moves across the screen like its wading through molasses. Ridiculous!

    #2
    I haven't noticed any problems for me.
    Canadian bacon is a fraud !!!!

    Comment


      #3
      Why wouldn't you just use chrome?

      Comment


        #4
        I only use Edge to get points on my Microsoft Bing accounts. If not for that, I probably would have never noticed.

        Comment


          #5
          Originally posted by Scott C4/5 View Post
          I only use Edge to get points on my Microsoft Bing accounts. If not for that, I probably would have never noticed.
          I mine my bing points too, but other than that I like edge.

          Have you tried the chrome spoofer and binger extension in chrome to get your bing points ? WAY quicker that way.
          Canadian bacon is a fraud !!!!

          Comment


            #6
            I haven't noticed any performance problems, what are the specs of the machine you are running on? I use chrome mostly but for sites that have implemented adblock deterrents (like forbes.com) I use Edge, also use it for the Azure portal.

            Comment


              #7
              I'm beginning to think that it has something to do with the software for my smartnav headmouse. Edge is working better but its still a little sluggish... actually, since the update, my mouse has been "sticky" on everything.

              McLaren, I'm hesitant to use anything to get my bing points easier. When they had clubbing.com people got their accounts terminated for those sorts of hacks. Also, you get 5 extra daily points for clicking on the "Earn more points" link on non-Edge browsers. Then going to Edge for those extras.

              t8burst, my ACER laptop system consists of the following:
              Windows 10 Home 64bit
              Intel Core i5-6200U dual core 2.30 GHz
              12gb RAM
              Intel HD Graphics 520

              I did a fresh clean install about 6 weeks ago and had no problems prior.

              Comment


                #8
                I had to roll back to an earlier update/whatever. Volume was quiet. It was slow af. I could no longer connect to devices wirelessly.

                Comment


                  #9
                  Originally posted by NorthQuad View Post
                  I had to roll back to an earlier update/whatever. Volume was quiet. It was slow af. I could no longer connect to devices wirelessly.
                  My volume is low too... thought it was related but couldn't see how. But when I checked the restore points, there were none available.

                  Comment


                    #10
                    Apparently the audio problem is a bigger problem than the sluggish mouse trouble that I am having...
                    http://www.valuewalk.com/2017/04/fix...udio-problems/

                    Comment


                      #11
                      Yeah, I found the issue with my volume level as others had already posted the issue.

                      Comment


                        #12
                        Aside from the low volume problem, I have a glitch that causes the windows background wav sound file to play at random times. If Microsoft doesn't address the glitch and or announce anything else about it soon, I'll wipe it off and do a clean install of Windows 7.

                        Comment


                          #13
                          Windows had another update the other day which solved my audio problem but caused my Android emulator program to quit working. :-/

                          Comment


                            #14
                            Originally posted by Scott C4/5 View Post
                            I'm beginning to think that it has something to do with the software for my smartnav headmouse. Edge is working better but its still a little sluggish... actually, since the update, my mouse has been "sticky" on everything.

                            McLaren, I'm hesitant to use anything to get my bing points easier. When they had clubbing.com people got their accounts terminated for those sorts of hacks. Also, you get 5 extra daily points for clicking on the "Earn more points" link on non-Edge browsers. Then going to Edge for those extras.

                            t8burst, my ACER laptop system consists of the following:
                            Windows 10 Home 64bit
                            Intel Core i5-6200U dual core 2.30 GHz
                            12gb RAM
                            Intel HD Graphics 520

                            I did a fresh clean install about 6 weeks ago and had no problems prior.
                            After I did the upgrade on 10 my SmartNav was ''sticky'' also. I rolled back to the earlier 10 and it's working fine. Unfortunately I can't turn off or restart my laptop because it will automatically do the upgrade. I don't know how to get rid of that.

                            Comment


                              #15
                              My mouse was mainly "sticky" only when I used Microsoft Edge. Two days ago my cousin bought me a new HP ENVY laptop and it is sticky as hell. Its taken me 10 minutes to type this message using the on-screen keyboard and headmouse. I'm thinking of putting Windows 7 on it, otherwise I won't be able to use it.

                              Comment

                              Working...
                              X